const regex = /^[A-Z]{1,4}-[0-9]{1,4}:\s(\w*)(\((\w+)\))?:\s(.*)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]{1,4}-[0-9]{1,4}:\\s(\\w*)(\\((\\w+)\\))?:\\s(.*)$', 'mg')
const str = `AAAA-12: fix(test): fixed the failing test
AAAA-12: fix: fixed the failing test
AAAA-12: fix(): fixed the failing test
AAAA-12(): fix: fixed the failing test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}