re = /^[A-Z]{1,4}-[0-9]{1,4}:\s(\w*)(\((\w+)\))?:\s(.*)$/m
str = 'AAAA-12: fix(test): fixed the failing test
AAAA-12: fix: fixed the failing test
AAAA-12: fix(): fixed the failing test
AAAA-12(): fix: fixed the failing test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end