#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<elementIdentifier>\.F)\/(?<airlineandFlightNumber>[A-Z0-9]{2,3}[A-Z0-9]{3,4})\/(?<date>[0-9]{2}[A-Z]{3})\/(?<destinationAirportCode>[A-Z]{3})\/?(?<classOfTravelOfBaggage>[A-Z0-9]{1})?"
Local $sString = ".F/SR101/16APR/JFK/J" & @CRLF & _
".F/AF0703/04JAN/CDG/Y" & @CRLF & _
".F/AF0703/04JAN/CDG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")