package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),(?<email>[^@]*@[^,]*),`)
var str = `123,s@gmail.com,abc
124,g@gmail.com,f@gmail.com,bcd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}