$re = '/(?m)(?:^(?=.*&.*&)|(?!^)\G)[^&\n]*\K&(?=.*&)/';
$str = 'GROUP 1
GROUP 1 & GROUP 2
GROUP 1 & GROUP 2 & GROUP 3
GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4
';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;