package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[(]([^()@[:space:]]+@[^()[:space:]]+[.][^()[:space:]]+)[)]`)
var str = `Mark Johnson (mark@johnson.com)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}