$re = '/(?:"[^"]+"|[^" ]+)?(\s*)/m';
$str = ' apple orange "g r a p e" pear "blue berry" pineapple ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);