package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<street>[^,]+), (?<city>[^,]+), (?<state>[^,]+), (?<zip>[^,]+)`)
var str = `123 Main Street, New York, NY, 10110`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}