package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(.*\)|[^\s]+`)
var str = `A >= 10 AND B <= 20 OR C in ('3', '4')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}