const regex = /<Number>(\d+\s)+<\/Number>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<Number>(\\d+\\s)+<\\\/Number>', 'gm')
const str = `something else
<Number>65
46
4564
132
654
132
1565
</Number>
something other`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}