using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w\d]+([+.][\w\d]+)*@$";
string input = @"john.seed@
bennormw@
john..seed@
john.+++.+.seed@
john..seed@
.john.seed@
+john.seed@
john.seed.++.+.@
john.seed@
a.@
d.d@
d+d@
d+.d@
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}