package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\d]+([+.][\w\d]+)*@$`)
var str = `john.seed@
bennormw@
john..seed@
john.+++.+.seed@
john..seed@
.john.seed@
+john.seed@
john.seed.++.+.@
john.seed@
a.@
d.d@
d+d@
d+.d@
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}