// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w\d]+([+.][\w\d]+)*@$").unwrap();
let string = "john.seed@
bennormw@
john..seed@
john.+++.+.seed@
john..seed@
.john.seed@
+john.seed@
john.seed.++.+.@
john.seed@
a.@
d.d@
d+d@
d+.d@
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}