package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(https?:\/\/)?steamcommunity\.com\/tradeoffer\/new\/\?partner=[0-9]+&token=[a-zA-Z0-9_-]+$`)
var str = `http://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
https://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
http://steamcommunity.com/tradeoffer/new/?partner=23&token=
http://steamcommunity.com/tradeoffer/new/?partner=&token=KasdTM
http://google.com/tradeoffer/new/?partner=23&token=KasdTM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}