import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/)?steamcommunity\\.com\\/tradeoffer\\/new\\/\\?partner=[0-9]+&token=[a-zA-Z0-9_-]+$";
final String string = "http://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM\n\n"
+ "https://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM\n\n"
+ "steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM\n\n"
+ "http://steamcommunity.com/tradeoffer/new/?partner=23&token=\n\n"
+ "http://steamcommunity.com/tradeoffer/new/?partner=&token=KasdTM\n\n"
+ "http://google.com/tradeoffer/new/?partner=23&token=KasdTM";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}