const regex = /^(https?:\/\/)?steamcommunity\.com\/tradeoffer\/new\/\?partner=[0-9]+&token=[a-zA-Z0-9_-]+$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:\\\/\\\/)?steamcommunity\\.com\\\/tradeoffer\\\/new\\\/\\?partner=[0-9]+&token=[a-zA-Z0-9_-]+$', 'igm')
const str = `http://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
https://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
http://steamcommunity.com/tradeoffer/new/?partner=23&token=
http://steamcommunity.com/tradeoffer/new/?partner=&token=KasdTM
http://google.com/tradeoffer/new/?partner=23&token=KasdTM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}