using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-V][a-vxyỳọáầảấờễàạằệếýộậốũứĩõúữịỗìềểẩớặòùồợãụủíỹắẫựỉỏừỷởóéửỵẳẹèẽổẵẻỡơôưăêâđ]+([ ][A-V][a-vxyỳọáầảấờễàạằệếýộậốũứĩõúữịỗìềểẩớặòùồợãụủíỹắẫựỉỏừỷởóéửỵẳẹèẽổẵẻỡơôưăêâđ]*)*$";
string input = @"Lê Thanh Toàn
Nguyen Thanh Toan
Le Nguyen Thanh Toan
Le Tran Nguyen Bui Huynh Thanh Toan
Le Toan
Le T
Toan
Toàn
nguyen
nguyen nam
nguyen long
nguyen Thanh
Nguyen thanh
Le Toan
NguyeN NaM LonG";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}