$re = '/\s(?\'dup\'\w*\s)\g\'dup\'/m';
$str = 'This is is a test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);