#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)\s?°\s?(\d+)\s?'\s?(\d+\.?\,?\d*?)"\s?(N|W|S|E)"
Local $sString = "15° 1' 36.991" E" & @CRLF & _
"15° 2' 21.421" E" & @CRLF & _
"15° 2' 0.712" E" & @CRLF & _
"15° 2' 45.181" E" & @CRLF & _
"15° 3' 1.709" E" & @CRLF & _
"14° 58' 24.822" E" & @CRLF & _
"14° 58' 39.840" E" & @CRLF & _
"14° 58' 26.234" E" & @CRLF & _
"14° 58' 45.145" E" & @CRLF & _
"15° 0' 14.01" E" & @CRLF & _
"15° 0' 11.460" E" & @CRLF & _
"15° 0' 7.928" E" & @CRLF & _
"15° 1' 53.693" S" & @CRLF & _
"15° 2' 24.699" E" & @CRLF & _
"15° 2' 45.547" E" & @CRLF & _
"15° 2' 12.837" E" & @CRLF & _
"15° 2' 43.594" E" & @CRLF & _
"15° 2' 31.644" E" & @CRLF & _
"15° 3' 1.059" E" & @CRLF & _
"14° 59' 46.315" E" & @CRLF & _
"14° 59' 31.694" E" & @CRLF & _
"15° 2' 41.057" E" & @CRLF & _
"14° 58' 40.068" E" & @CRLF & _
"36°57'9" N"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")