# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)\s?°\s?(\d+)\s?'\s?(\d+\.?\,?\d*?)\"\s?(N|W|S|E)"
test_str = ("15° 1' 36.991\" E\n"
"15° 2' 21.421\" E\n"
"15° 2' 0.712\" E\n"
"15° 2' 45.181\" E\n"
"15° 3' 1.709\" E\n"
"14° 58' 24.822\" E\n"
"14° 58' 39.840\" E\n"
"14° 58' 26.234\" E\n"
"14° 58' 45.145\" E\n"
"15° 0' 14.01\" E\n"
"15° 0' 11.460\" E\n"
"15° 0' 7.928\" E\n"
"15° 1' 53.693\" S\n"
"15° 2' 24.699\" E\n"
"15° 2' 45.547\" E\n"
"15° 2' 12.837\" E\n"
"15° 2' 43.594\" E\n"
"15° 2' 31.644\" E\n"
"15° 3' 1.059\" E\n"
"14° 59' 46.315\" E\n"
"14° 59' 31.694\" E\n"
"15° 2' 41.057\" E\n"
"14° 58' 40.068\" E\n"
"36°57'9\" N")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.