$re = '/(\w+) \(Vendeur : \'([^\']*)\' \/ Amazon : \'([^\']*)\'/m';
$str = 'correspondent à l\'ASIN B00WU8XXXX, mais les attributs suivants sont en conflit avec : product_type (Vendeur : \'APPLIANCE_ACCESSORY\' / Amazon : \'CLEANING_AGENT\'), ean (Vendeur : \'400650819XXXX\' / Amazon : \'400650819XXXX\'), item_package_quantity (Vendeur : \'5\' / Amazon : \'10\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);