$re = '/[$](\{)?\w+(?(1)(?:[\/:].*})?)/m';
$str = '$TM_FILENAME
${TM_FILENAME/[\\.]/_/}
${1:OPT1|OPT2}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);