# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"construit \w{2,4} (lieu|sein|plusieurs|parpaings|face|forme|immeuble|(\d+|\w{2,10}) ([ée]tapes|phases)|ossature|siporex|plaques|charpente|rez.*|rdc|cloison|\d+ fois|r\+\d+)"
test_str = ("[NE PAS TENIR COMPTE]\n"
"construit en lieu\n"
"construit en plusieurs\n"
"construit en parpaings\n"
"construit en face\n"
"construit en forme\n"
"construit en immeuble\n"
"construit en deux étapes\n"
"construit en ossature\n"
"construit en siporex\n"
"construit en plaques béton\n"
"construit en charpente \n"
"construit en rez-de-chaussé\n"
"construit en 2 phases\n"
"construit en cloison\n"
"construit en 3 fois \n"
"construit en r+1 \n"
"construit en lieu\n\n"
"construit au sein d'un complexe\n"
"construit sur une parcelle")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.