#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^([1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.)(((0|[1-9][0-9]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.){2})(0|[1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])$"
Local $sString = "1.1.1.1" & @CRLF & _
"10.10.10.10" & @CRLF & _
"255.255.255.255" & @CRLF & _
"1.255.1.123" & @CRLF & _
"0.1.1.1" & @CRLF & _
"1.0.0.0" & @CRLF & _
"1.1.1.1" & @CRLF & _
"255.256.255.255" & @CRLF & _
"127.0.0.1" & @CRLF & _
".127.0.0.1" & @CRLF & _
"q.0.0.0" & @CRLF & _
"t.t.t.t" & @CRLF & _
"44.44.44.44" & @CRLF & _
"44.44.44.444" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")