$re = '/(\d)(?!\1)\d\1/m';
$str = '123456
110100
110000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);