#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?|((?:" & @CRLF & _
" m(?=a)" & @CRLF & _
" |(?<=m)a" & @CRLF & _
" |a(?=x)" & @CRLF & _
" |(?<=a)x" & @CRLF & _
" |x(?=m)" & @CRLF & _
" |(?<=x)m" & @CRLF & _
" |m(?=u)" & @CRLF & _
" |(?<=m)u" & @CRLF & _
" |u(?=s)" & @CRLF & _
" |(?<=u)s" & @CRLF & _
" |s(?=t)" & @CRLF & _
" |(?<=s)t" & @CRLF & _
" |t(?=e)" & @CRLF & _
" |(?<=t)e" & @CRLF & _
" |e(?=r)" & @CRLF & _
" |(?<=e)r" & @CRLF & _
")+)|([maxmuster]))"
Local $sString = "maxmx dfgdfg" & @CRLF & _
"Mymaxmusis" & @CRLF & _
"Lemdfgudf" & @CRLF & _
"muster" & @CRLF & _
"mustr" & @CRLF & _
"zxmus" & @CRLF & _
"stackoverflow"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")