import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|((?:\n"
+ " m(?=a)\n"
+ " |(?<=m)a\n"
+ " |a(?=x)\n"
+ " |(?<=a)x\n"
+ " |x(?=m)\n"
+ " |(?<=x)m\n"
+ " |m(?=u)\n"
+ " |(?<=m)u\n"
+ " |u(?=s)\n"
+ " |(?<=u)s\n"
+ " |s(?=t)\n"
+ " |(?<=s)t\n"
+ " |t(?=e)\n"
+ " |(?<=t)e\n"
+ " |e(?=r)\n"
+ " |(?<=e)r\n"
+ ")+)|([maxmuster]))";
final String string = "maxmx dfgdfg\n"
+ "Mymaxmusis\n"
+ "Lemdfgudf\n"
+ "muster\n"
+ "mustr\n"
+ "zxmus\n"
+ "stackoverflow";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}