#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+) +(@\S+@)? *(\S+) +(.*)"
Local $sString = "0 HEAD" & @CRLF & _
"1 CHAR UTF-8" & @CRLF & _
"1 SOUR Ancestry.com Family Trees" & @CRLF & _
"2 VERS (2010.3)" & @CRLF & _
"2 NAME Ancestry.com Family Trees" & @CRLF & _
"2 CORP Ancestry.com" & @CRLF & _
"1 GEDC" & @CRLF & _
"2 VERS 5.5" & @CRLF & _
"2 FORM LINEAGE-LINKED" & @CRLF & _
"0 @P6@ INDI " & @CRLF & _
"1 BIRT "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")