// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:40\d[0-5]|[1-3]\d{3}|[1-9]\d?\d?|0),?\b){4}$").unwrap();
let string = "0,1,3,9
12,99,999,4095
99,999,3999,4095
1200,2500,2000,90
01,002,003,0
99,999,3999,4096
1200,2500,6500,90
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}