re = /\b(?![A-Z]{7})[A-Z\d]{7}\b/m
str = 'I want this nr A7A3G1A but not this ANTENNA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end