package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(\s|.)*\bLONG BLOB\b`)
var str = `add
CHARACTER SET
COLLATE long blob `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}