# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/fruit_id "([^"]*)"; salad_id "";/fruit_id "\1"; salad_id "\1";/gm;t' <<< "fruit_id \"Apple\"; salad_id \"\";
fruit_id \"Mango\"; salad_id \"\";
fruit_id \"Kiwi\"; salad_id \"\"; "