const regex = /^[^`~!@#$%^&*()_+={}\[\]|\\:;“’<,>.?๐฿]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^`~!@#$%^&*()_+={}\\[\\]|\\\\:;“’<,>.?๐฿]*$', 'gm')
const str = `asdad
sdf@323
asdasdadq@3333
[][]asd
dddddd[
127 elmer road ??<>()`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}