package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^My name is '([^']+)' and I live in (.+?)(?:$| capital$| capital and I like (.+?)(?: programming|$))`)
var str = `My name is 'Mark' and I live in Spain capital and I like computers programming
My name is 'Mark' and I live in Spain capital and I like computers
My name is 'Mark' and I live in Spain capital
My name is 'Mark' and I live in Spain`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}