// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^My name is '([^']+)' and I live in (.+?)(?:$| capital$| capital and I like (.+?)(?: programming|$))").unwrap();
let string = "My name is 'Mark' and I live in Spain capital and I like computers programming
My name is 'Mark' and I live in Spain capital and I like computers
My name is 'Mark' and I live in Spain capital
My name is 'Mark' and I live in Spain";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}