package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.edu(?:\.\w{2,3})?$`)
var str = `.xx
school.edu.au
college.edu.uk
.edu
school.edu
student.college.edu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}