# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"url(\(((?:[^()]+|(?1))+)\))"
test_str = ("\n"
"url(https://exemples.com/fonts/lato/lato/lato-regular-webfont.ttf)\n"
"src:url(https://exemples.com/fonts/lato/lato-regular-webfont.eot?#iefix)\n"
"background:url(https://exemples.com/product/header/img.png)\n"
"background:url(/product/header/img.png)\n"
"background:url(\"/product/header/img.png\")\n"
"background:url('/product/header/img.png')\n"
"background:url(/uploads/2019/03/0002-image(thumbnail_product).jpg)\n\n"
".card-thumb__img1{display:block;width:142px;height:62px;background:url(https://example.com/product01.jpg) center center no-repeat;background-size:contain}@media (max-width:1029px).card-thumb__img2{display:block;z-index:1;background:url(https://example.com/product02.jpg) center center no-repeat #000;\n\n"
"background-image: url(/uploads/2019/03/product01-image(thumbnail_photo).jpg); ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.