package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:\t| {4})+)`)
var str = `def calc_value(a, b, c): if a>b+c: return a else: return b`
var substitution = "\n\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}