$re = '/((?:\t| {4})+)/';
$str = 'def calc_value(a, b, c): if a>b+c: return a else: return b';
$subst = "\n\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;