// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:\t| {4})+)").unwrap();
let string = "def calc_value(a, b, c): if a>b+c: return a else: return b";
let substitution = "\\n\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}