Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
({})\1|[{]\s*?(\S*?|\S*?\(.*?\)|['][^']*?[']|["][^"]*?["]|["][^"]*?["]\.\(.*?\))(?:!(\S+?))?\s*?[}]
/
g
Input 1
1
New
{0.concat("8a b c d e", 6)} s df s sd{"one field name".toFixed(7 , 8)} kjnkj sd asdvs ds sd{0.concat("8a b c d e", 6)} ascdac{ "one fieldname".toFixed(7 , 8) } ascdac{ "onefi eldname" } {onefieldname.toFixed(7 , 8)} dfgsdg { "onefieldname".toFixed(7 , 8)} {onefieldname: "toFixed(7 , 8)"} {"onefieldname": "toFixed(7 , 8)"} { "onefiel dname" : "toFixed(7 , 8)"} { "onefiel dname": 8} { "onefiel dname" : {"onefi eldname".toFixed(7 , 8)} } { "onefiel dname" : {"onefi eldname".toFixed(7 , 8) }} { "onefiel dname" : {onefieldname.toFixed(7 , 8)} } { "onefiel dname" : { onefieldname.toFixed(7 , 8)} }