# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!\d{2}\h*[:-]\h*\d{2}\h*$).*[\r\n]+"
test_str = ("01 - 10\n"
"This is the first one :1\n"
"02:45\n"
"This is the second one -2\n"
"03-88\n"
"This is the third one \"3\n"
"04:40\n"
"This is the forth one ;4\n"
"05 - 50\n"
"This is the fifth one .5")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.