import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"name\":\"[^\"]+\")|(\"price\":(?:\\d{1,3}.?)+[.,]\\d{1,2})";
final String string = "[{\"productsShelf\":[],\"productsDetail\":[{\"position\":\"1\",\"name\":\"Placa-M�e ASUS p/ Intel LGA 1151 ATX ROG STRIX Z270E GAMING,DDR4,Aura Sync, �udio Gamer, Rede Intel, SLI/CFX, Wi-Fi, USB 3.1 Frontal,HDMI/DP\",\"category\":\"Hardware/Placas-m�e/P/ Processador Intel/ASUS\",\"brand\":\"Asus;\",\"price\":1095.9,\"id\":\"84264\",\"available\":true}],\"visitor\":\"\",\"pageType\":\"product\",\"breadcrumb\":[{\"url\":\"http://www.kabum.com.br/hardware\",\"name\":\"Hardware\"},{\"url\":\"http://www.kabum.com.br/hardware/placas-mae\",\"name\":\"Placas-m�e\"},{\"url\":\"http://www.kabum.com.br/hardware/placas-mae/p-processador-intel\",\"name\":\"P/ Processador Intel\"},{\"url\":\"http://www.kabum.com.br/hardware/placas-mae/p-processador-intel/asus\",\"name\":\"ASUS\"}]}];";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}