import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!([\\u4e00-\\u9fa5]|\\w+)).";
final String string = "汉字测试通过 123 2\n"
+ "12313\n"
+ "sfdsdfs--\n"
+ "😂自行车🚲\n"
+ "----\n"
+ "[`~!@%#$^&*()=|{}':;', \\\\[\\\\]<>/? /\]\\\\.;:%……+ ¥()【】‘”“'.。,、?1234567890-=_+~?!@#$%^&*)]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}