#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=^(?:...(?:....)*)?)r"
Local $sString = "it is a test string." & @CRLF & _
"rxxrxxxrxxxrxxxrxxxr" & @CRLF & _
"rrrrrrrrrrrrrrrrrrrr"
Local $sSubst = "m"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)