$re = '/(?<=^(?:...(?:....)*)?)r/m';
$str = 'it is a test string.
rxxrxxxrxxxrxxxrxxxr
rrrrrrrrrrrrrrrrrrrr';
$subst = "m";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;