use strict;
my $str = 'Hitre Spletne Strani n\'123 t-t o.';
my $regex = qr/^[a-zA-Z0-9ČŠŽĐ'.](?:[A-Z0-9 ČŠŽĐ'.\-]{0,31}[A-Z0-9ČŠŽĐ'.])?$/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}