// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^[a-zA-Z0-9ČŠŽĐ'.](?:[A-Z0-9 ČŠŽĐ'.\-]{0,31}[A-Z0-9ČŠŽĐ'.])?$").unwrap();
let string = "Hitre Spletne Strani n'123 t-t o.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}