re = /^X(?!([^-\n]*-){2})(?=[^A-Z\n]*[A-Z])[A-Z\d-]{3,6}$/m
str = 'XABC
XA-BC8D
X-ABC
XB72D-
X123
XAB
XABC-123
XA--BC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end