#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b-\d{1,3}-\d{1,3}-\d{1,3}(?::\d)?"
Local $sString = "r-1-1-1" & @CRLF & _
"r-1-1-1:3" & @CRLF & _
"-1-1-1" & @CRLF & _
"-1-1-1:3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")